using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w-]+)";
string input = @"/pathvalue1/path-value-one
/pathvalue2/path-value
/pathvalue3/pathvaluethree";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}