// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\w-]+)").unwrap();
let string = "/pathvalue1/path-value-one
/pathvalue2/path-value
/pathvalue3/pathvaluethree";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}