import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*\\{\\{source\\|(?>[^\\{\\}]|(\\{\\{(?:[^\\{\\}]++|(?1))*\\}\\}))*\\}\\}\\s*";
final String string = "# Test is a cool word {{source|{{nom w pc|Chantal|Bouchard}}, ''La langue et le nombril'', Presses de l'Université de Montréal (PUM), 2020, p. 174}}.\n"
+ "# Test is a cool word {{source|Nicolas|Daniel, Presses de l'Université de Montréal 4}}";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}