re = /\s*\{\{source\|(?>[^{}]|(\{\{(?:[^{}]++|(?1))*}}))*}}\s*/m
str = '# Test is a cool word {{source|{{nom w pc|Chantal|Bouchard}}, \'\'La langue et le nombril\'\', Presses de l\'Université de Montréal (PUM), 2020, p. 174}}.
# Test is a cool word {{source|Nicolas|Daniel, Presses de l\'Université de Montréal 4}}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result