#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\n+|\t+|\r+|\s{2,}"
Local $sString = ".b-block_warranty__side_right-end-link{" & @CRLF & _
" outline:none !important;" & @CRLF & _
" font-size:14px;" & @CRLF & _
" line-height:16px;" & @CRLF & _
" color:#64a0d1;" & @CRLF & _
" font-weight:400;" & @CRLF & _
" border-bottom:1px dashed #64a0d1;" & @CRLF & _
" -webkit-transition:all 0.5s ease;" & @CRLF & _
" -o-transition:all 0.5s ease;" & @CRLF & _
" transition:all 0.5s ease;" & @CRLF & _
"}" & @CRLF & _
".b-block_warranty__side_right-end-link_hidden{" & @CRLF & _
" display:none;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")