use strict;
my $str = '.b-block_warranty__side_right-end-link{
outline:none !important;
font-size:14px;
line-height:16px;
color:#64a0d1;
font-weight:400;
border-bottom:1px dashed #64a0d1;
-webkit-transition:all 0.5s ease;
-o-transition:all 0.5s ease;
transition:all 0.5s ease;
}
.b-block_warranty__side_right-end-link_hidden{
display:none;
}';
my $regex = qr/\n+|\t+|\r+|\s{2,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}