import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(script|style)[^>]*>[\\s\\S]*?<\\/\\1>|<\\/?[^>]+>";
final String string = "<div class=\"my_class\">\n"
+ " <div class=\"copy\">\n"
+ " © 2018 Texto\n"
+ " </div>\n"
+ " </div>\n\n"
+ "<div class=\"my_class\">\n"
+ " <h1>¿como estas?</h1>\n"
+ " <div class=\"copy\">\n"
+ " © 2018 Texto\n"
+ " </div>\n"
+ "<script>\n"
+ "function hola(){\n\n"
+ "}\n"
+ "</script>\n"
+ "<style>\n"
+ ".red{\n"
+ " background-color: red;\n"
+ "}\n"
+ "</style>\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}