import Foundation
let pattern = #"<(script|style)[^>]*>[\s\S]*?<\/\1>|<\/?[^>]+>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="my_class">
<div class="copy">
© 2018 Texto
</div>
</div>
<div class="my_class">
<h1>¿como estas?</h1>
<div class="copy">
© 2018 Texto
</div>
<script>
function hola(){
}
</script>
<style>
.red{
background-color: red;
}
</style>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)