using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"M(\d{1,3})[-_]\d{1,4}(CCU?|)";
string input = @"DOA000281_ICS_U-M1-300_R-Zero_S.TAB
DOA000281_ICS_U-M10-300_R-Zero_S.TAB
DOA000281_ICS_U-M100-300_R-Zero_S.TAB
DOA000281_ICS_U-M2-300_R-Zero_S.TAB
DOA000281_ICS_U-M200-300CCU_R-Zero_S.TAB
DOA000281_ICS_U-M200-300_R-Zero_S.TAB
DOA000281_ICS_U-M30-300CCU_R-Zero_S.TAB
DOA000281_ICS_U-M30-300_R-Zero_S.TAB
DOA000281_ICS_U-M5-300_R-Zero_S.TAB
DOA000281_ICS_U-M50-300_R-Zero_S.TAB
DOA_000533_ICS_100y180s_0y0sMax.tab
DOA_000533_ICS_10y180s_0y0sMax.tab
DOA_000533_ICS_1y180s_0y0sMax.tab
DOA_000533_ICS_200ccy180s_0y0sMax.tab
DOA_000533_ICS_200y180s_0y0sMax.tab
DOA_000533_ICS_2y180s_0y0sMax.tab
DOA_000533_ICS_30ccy180s_0y0sMax.tab
DOA_000533_ICS_30y180s_0y0sMax.tab
DOA_000533_ICS_50y180s_0y0sMax.tab
DOA_000533_ICS_5y180s_0y0sMax.tab
CFA_AUG2018_2D DOA_000537_ICS_100y600s_0y0sMax.TAB
CFA_AUG2018_2D DOA_000537_ICS_10y600s_0y0sMax.TAB
CFA_AUG2018_2D DOA_000537_ICS_1y600s_0y0sMax.TAB
CFA_AUG2018_2D DOA_000537_ICS_200ccy600s_0y0sMax.TAB
CFA_AUG2018_2D DOA_000537_ICS_200y600s_0y0sMax.TAB
CFA_AUG2018_2D DOA_000537_ICS_2y600s_0y0sMax.TAB
CFA_AUG2018_2D DOA_000537_ICS_30ccy600s_0y0sMax.TAB
CFA_AUG2018_2D DOA_000537_ICS_30y600s_0y0sMax.TAB
CFA_AUG2018_2D DOA_000537_ICS_50y600s_0y0sMax.TAB
CFA_AUG2018_2D DOA_000537_ICS_5y600s_0y0sMax.TAB
DOA000557_ICS_U-M1-60_R-Zero_S_2D.TAB
DOA000557_ICS_U-M10-60_R-Zero_S_2D.TAB
DOA000557_ICS_U-M100-60_R-Zero_S_2D.TAB
DOA000557_ICS_U-M2-60_R-Zero_S_2D.TAB
DOA000557_ICS_U-M200-60CCU_R-Zero_S_2D.TAB
DOA000557_ICS_U-M200-60_R-Zero_S_2D.TAB
DOA000557_ICS_U-M30-60CCU_R-Zero_S_2D.TAB
DOA000557_ICS_U-M30-60_R-Zero_S_2D.TAB
DOA000557_ICS_U-M5-60_R-Zero_S_2D.TAB
DOA000557_ICS_U-M50-60_R-Zero_S_2D.TAB
DOA000616_617 ICS U-M1-60_R-ZERO_Summer.TAB
DOA000616_617 ICS U-M10-60_R-ZERO_Summer.TAB
DOA000616_617 ICS U-M100-60_R-ZERO_Summer.TAB
DOA000616_617 ICS U-M2-60_R-ZERO_Summer.TAB
DOA000616_617 ICS U-M200-60CCU_R-ZERO_Summer.TAB
DOA000616_617 ICS U-M200-60_R-ZERO_Summer.TAB
DOA000616_617 ICS U-M30-60CCU_R-ZERO_Summer.TAB
DOA000616_617 ICS U-M30-60_R-ZERO_Summer.TAB
DOA000616_617 ICS U-M5-60_R-ZERO_Summer.TAB
DOA000616_617 ICS U-M50-60_R-ZERO_Summer.TAB
DOA000674_ICS_U_M100_120_R_Zero_S.TAB
DOA000674_ICS_U_M10_120_R_Zero_S.TAB
DOA000674_ICS_U_M1_120_R_Zero_S.TAB
DOA000674_ICS_U_M200_120CCU_R_Zero_S.TAB
DOA000674_ICS_U_M200_120_R_Zero_S.TAB
DOA000674_ICS_U_M2_120_R_Zero_S.TAB
DOA000674_ICS_U_M30_120CCU_R_Zero_S.TAB
DOA000674_ICS_U_M30_120_R_Zero_S.TAB
DOA000674_ICS_U_M50_120_R_Zero_S.TAB
DOA000674_ICS_U_M5_120_R_Zero_S.TAB
DOA002372_ICS_U_M100_120_R_Zero_S_2D.TAB
DOA002372_ICS_U_M10_120_R_Zero_S_2D.TAB
DOA002372_ICS_U_M1_120_R_Zero_S_2D.TAB
DOA002372_ICS_U_M200_120CC_R_Zero_S_2D.TAB
DOA002372_ICS_U_M200_120_R_Zero_S_2D.TAB
DOA002372_ICS_U_M2_120_R_Zero_S_2D.TAB
DOA002372_ICS_U_M30_120CC_R_Zero_S_2D.TAB
DOA002372_ICS_U_M30_120_R_Zero_S_2D.TAB
DOA002372_ICS_U_M50_120_R_Zero_S_2D.TAB
DOA002372_ICS_U_M5_120_R_Zero_S_2D.TAB
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}