using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<if>#if\((?<ifContents>[^\)]+)\))(?<ifResult>[\s\S]+?)(?=#elif|#else|#end)(?<elIf>#elif[\s\S]+?(?=#else|#end))?(?<else>#else([\s\S]+?(?=#end)))?[\s\S]*?#end";
string input = @"NOTE: because regex doesn't support multiple captures with 1 group the 'elif' part will be parsed in part 2.
Ignore
#if(#C.Age >= 18)
18+ lesgo
#end
Ignore
#if(#C.Age >= 18)
18+ lesgo
#else
No special thingy
#end
Ignore
#if(#C.Age >= 18)
18+ lesgo
#elif(#C.Length >= 1.9m)
Tall boi
#elif(#C.Name == bob)
Hi bob
#else
No special thingy
#end
Ignore
#if(#C.Age >= 18)18+ lesgo #elif(#C.Length >= 1.9m)Tall boi#elif(#C.Name == bob)Hi bob #elseNo special thingy#end
Ignore";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}