const regex = new RegExp('(?<if>#if\\((?<ifContents>[^\\)]+)\\))(?<ifResult>[\\s\\S]+?)(?=#elif|#else|#end)(?<elIf>#elif[\\s\\S]+?(?=#else|#end))?(?<else>#else([\\s\\S]+?(?=#end)))?[\\s\\S]*?#end', 'ig')
const str = `NOTE: because regex doesn't support multiple captures with 1 group the 'elif' part will be parsed in part 2.
Ignore
#if(#C.Age >= 18)
18+ lesgo
#end
Ignore
#if(#C.Age >= 18)
18+ lesgo
#else
No special thingy
#end
Ignore
#if(#C.Age >= 18)
18+ lesgo
#elif(#C.Length >= 1.9m)
Tall boi
#elif(#C.Name == bob)
Hi bob
#else
No special thingy
#end
Ignore
#if(#C.Age >= 18)18+ lesgo #elif(#C.Length >= 1.9m)Tall boi#elif(#C.Name == bob)Hi bob #elseNo special thingy#end
Ignore`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}