use strict;
my $str = 'NOTE: because regex doesn\'t support multiple captures with 1 group the \'elif\' part will be parsed in part 2.
Ignore
#if(#C.Age >= 18)
18+ lesgo
#end
Ignore
#if(#C.Age >= 18)
18+ lesgo
#else
No special thingy
#end
Ignore
#if(#C.Age >= 18)
18+ lesgo
#elif(#C.Length >= 1.9m)
Tall boi
#elif(#C.Name == bob)
Hi bob
#else
No special thingy
#end
Ignore
#if(#C.Age >= 18)18+ lesgo #elif(#C.Length >= 1.9m)Tall boi#elif(#C.Name == bob)Hi bob #elseNo special thingy#end
Ignore';
my $regex = qr/(?<if>#if\((?<ifContents>[^\)]+)\))(?<ifResult>[\s\S]+?)(?=#elif|#else|#end)(?<elIf>#elif[\s\S]+?(?=#else|#end))?(?<else>#else([\s\S]+?(?=#end)))?[\s\S]*?#end/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}