$re = '/(?<if>#if\((?<ifContents>[^\)]+)\))(?<ifResult>[\s\S]+?)(?=#elif|#else|#end)(?<elIf>#elif[\s\S]+?(?=#else|#end))?(?<else>#else([\s\S]+?(?=#end)))?[\s\S]*?#end/i';
$str = 'NOTE: because regex doesn\'t support multiple captures with 1 group the \'elif\' part will be parsed in part 2.
Ignore
#if(#C.Age >= 18)
18+ lesgo
#end
Ignore
#if(#C.Age >= 18)
18+ lesgo
#else
No special thingy
#end
Ignore
#if(#C.Age >= 18)
18+ lesgo
#elif(#C.Length >= 1.9m)
Tall boi
#elif(#C.Name == bob)
Hi bob
#else
No special thingy
#end
Ignore
#if(#C.Age >= 18)18+ lesgo #elif(#C.Length >= 1.9m)Tall boi#elif(#C.Name == bob)Hi bob #elseNo special thingy#end
Ignore';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);