#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sim)^<(?<Direction>(Send|Recv)) TYPE=""(?<Function>.+?)"" UTC=""(?<date>.+?)"" ID=""(?<ID>.+?)""(?:\s*\/>|>(?<Message>.*?)<\/\1>)$"
Local $sString = "<Recv TYPE="Select.req" UTC="05.11.2024 01:43:35" ID="2130706432" />" & @CRLF & _
"<Send TYPE="Select.req" UTC="05.11.2024 01:43:35" ID="1152" />" & @CRLF & _
"<Send TYPE="Select.rsp" UTC="05.11.2024 01:43:35" ID="2130706432" />" & @CRLF & _
"<Send TYPE="S1F13W" UTC="05.11.2024 01:43:35" ID="1153">" & @CRLF & _
" <List Items="2">" & @CRLF & _
" <Ascii Size="17" ItemName="MDLN">SECSService</Ascii>" & @CRLF & _
" <Ascii Size="20" ItemName="SOFTREV">1.0</Ascii>" & @CRLF & _
" </List>" & @CRLF & _
"</Send>" & @CRLF & _
"<Recv TYPE="Select.rsp" UTC="05.11.2024 01:43:35" ID="1152" />" & @CRLF & _
"<Recv TYPE="S1F14" UTC="05.11.2024 01:43:36" ID="1153">" & @CRLF & _
" <List Items="2">" & @CRLF & _
" <Binary Size="4">0x00</Binary>" & @CRLF & _
" <List Items="0" />" & @CRLF & _
" </List>" & @CRLF & _
"</Recv>" & @CRLF & _
"<Recv TYPE="S1F13W" UTC="05.11.2024 01:43:36" ID="1">" & @CRLF & _
" <List Items="0" />" & @CRLF & _
"</Recv>" & @CRLF & _
"<Send TYPE="S2F34" UTC="05.11.2024 01:43:38" ID="4">" & @CRLF & _
" <Binary Size="4" ItemName="DRACK">0x00</Binary>" & @CRLF & _
"</Send>" & @CRLF & _
"<Recv TYPE="S2F37W" UTC="05.11.2024 01:43:39" ID="5">" & @CRLF & _
" <List Items="2">" & @CRLF & _
" <Boolean Size="5">False</Boolean>" & @CRLF & _
" <List Items="17">" & @CRLF & _
" <UInt32 Size="1">1</UInt32>" & @CRLF & _
" <UInt32 Size="1">2</UInt32>" & @CRLF & _
" <UInt32 Size="1">3</UInt32>" & @CRLF & _
" <UInt32 Size="1">5</UInt32>" & @CRLF & _
" <UInt32 Size="1">6</UInt32>" & @CRLF & _
" <UInt32 Size="2">10</UInt32>" & @CRLF & _
" <UInt32 Size="2">11</UInt32>" & @CRLF & _
" <UInt32 Size="2">20</UInt32>" & @CRLF & _
" <UInt32 Size="2">21</UInt32>" & @CRLF & _
" <UInt32 Size="2">22</UInt32>" & @CRLF & _
" <UInt32 Size="2">40</UInt32>" & @CRLF & _
" <UInt32 Size="2">41</UInt32>" & @CRLF & _
" <UInt32 Size="2">42</UInt32>" & @CRLF & _
" <UInt32 Size="2">50</UInt32>" & @CRLF & _
" <UInt32 Size="2">52</UInt32>" & @CRLF & _
" <UInt32 Size="2">70</UInt32>" & @CRLF & _
" <UInt32 Size="2">71</UInt32>" & @CRLF & _
" </List>" & @CRLF & _
" </List>" & @CRLF & _
"</Recv>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")