# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(:2(\[(((\d*,){3})\]))).*/$4/g;t' <<< ":1[2,2,2,]:2[0,14,88,]:homebase[7,4,1776,]:"