#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*(:2(\[(((\d*,){3})\]))).*"
Local $sString = ":1[2,2,2,]:2[0,14,88,]:homebase[7,4,1776,]:"
Local $sSubst = "$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)