using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(:2(\[(((\d*,){3})\]))).*";
string substitution = @"$4";
string input = @":1[2,2,2,]:2[0,14,88,]:homebase[7,4,1776,]:";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}