const regex = /.*(:2(\[(((\d*,){3})\]))).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(:2(\\[(((\\d*,){3})\\]))).*', 'g')
const str = `:1[2,2,2,]:2[0,14,88,]:homebase[7,4,1776,]:`;
const subst = `$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);