re = /.*(:2(\[(((\d*,){3})\]))).*/
str = ':1[2,2,2,]:2[0,14,88,]:homebase[7,4,1776,]:'
subst = '$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result