import Foundation
let pattern = #".*(:2(\[(((\d*,){3})\]))).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #":1[2,2,2,]:2[0,14,88,]:homebase[7,4,1776,]:"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)