#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.+?)(<p>.+?<\/p>)"
Local $sString = "this is some <b>text</b><p>Beginning of a paragraph</p>"
Local $sSubst = "<p>$1<\/p>$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)