package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^((http:\/\/|https:\/\/)?(www\.)?)`)
var str = `http://example.com
https://example.com
http://www.example.com
https://www.example.com
://www.example.com
www.example.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}