re = /^((http:\/\/|https:\/\/)?(www\.)?)/mi
str = 'http://example.com
https://example.com
http://www.example.com
https://www.example.com
://www.example.com
www.example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end