package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((\([^()]*(?2)?[^()]*\))|\S+).ToHashSet\(\)`)
var str = `____.ToHashSet()
(something).ToHashSet()
(some (nested (object) i ) need).ToHashSet()
(some
(nested (object) with )
linebreaks).ToHashSet()`
var substitution = "new HashSet<placeholder>($1)"
fmt.Println(re.ReplaceAllString(str, substitution))
}