const regex = /((\([^()]*(?2)?[^()]*\))|\S+).ToHashSet\(\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\([^()]*(?2)?[^()]*\\))|\\S+).ToHashSet\\(\\)', 'gm')
const str = `____.ToHashSet()
(something).ToHashSet()
(some (nested (object) i ) need).ToHashSet()
(some
(nested (object) with )
linebreaks).ToHashSet()`;
const subst = `new HashSet<placeholder>($1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);