use strict;
my $str = '____.ToHashSet()
(something).ToHashSet()
(some (nested (object) i ) need).ToHashSet()
(some
(nested (object) with )
linebreaks).ToHashSet()';
my $regex = qr/((\([^()]*(?2)?[^()]*\))|\S+).ToHashSet\(\)/mp;
my $subst = 'new HashSet<placeholder>($1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";