import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=\\.)|\\s*^)\\s*(I )?hope (it|this|that)( will\\b| can\\b)? helps?( (you|someone(?:\\h*else)?)\\b)?(:-?\\)|🙂️|[!.;,\\s])*?(\\s*(cheers|good ?luck)([!,.]*))?$";
final String string = "Help it hopes";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}