using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(point).*(out)";
string input = @"I think we have to point certain things out to this man, and after that point some other things out to him too.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}