$re = '/(point).*?(out)/';
$str = 'I think we have to point certain things out to this man, and after that point some other things out to him too.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);