#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<a [^>]*href="https://www\.youtube\.com/watch\?v=([^"&]+)[^>]*>(?s:.*?)</a>"
Local $sString = "" & @CRLF & _
"<a target="_blank" href="https://www.youtube.com/watch?v=pahhmV4WUUU" >" & @CRLF & _
"</a>" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "<iframe width="560" height="315" src="https://www.youtube.com/embed/$1" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)