re = /<a [^>]*href="https:\/\/www\.youtube\.com\/watch\?v=([^"&]+)[^>]*>(?s:.*?)<\/a>/m
str = '
<a target="_blank" href="https://www.youtube.com/watch?v=pahhmV4WUUU" >
</a>
'
subst = '<iframe width="560" height="315" src="https://www.youtube.com/embed/$1" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result