#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "===Substantiv===(.*(?:\r?\n(?!\s*\r?\n).*)*)"
Local $sString = "===Substantiv===" & @CRLF & _
"Det var en gång en liten höna som gick på bio, fast det visste hon inte först." & @CRLF & _
"Alltså visste hon inte." & @CRLF & _
"Fast ändå var det ganska roligt för henne." & @CRLF & _
" " & @CRLF & _
"==Annat==" & @CRLF & _
"Trots att det var roligt var det inte det."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")