using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"===Substantiv===(.*(?:\r?\n(?!\s*\r?\n).*)*)";
string input = @"===Substantiv===
Det var en gång en liten höna som gick på bio, fast det visste hon inte först.
Alltså visste hon inte.
Fast ändå var det ganska roligt för henne.
==Annat==
Trots att det var roligt var det inte det.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}