re = /(?=^(?:.*a){3}.*$)(?=^(?:.*b){3}.*$)(?=^(?:.*c){3}.*$|^[^c]*$).*/m
str = 'aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
aaabbbc
aabbb
abbccc
abcabca'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end