package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:foo|bar)\h*)+$`)
var str = `foo
bar
barfoo
foobarbarfoofoobar
foo bar
foo foo bar
foo bar ipsum dolor sit amet, consectetur adipiscing elit
ipsum dolor sit amet, consectetur adipiscing elit foo
ipsum dolor sit amet, bar consectetur adipiscing elit foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}