$re = '/(\w)( )(\w)/m';
$str = '"\\|\\s*language\\s*=\\s*Freaslainnis Iartharach\\b" "|language=fy" \\';
$subst = "\1\\\2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;