// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^_]*)_(.*)$").unwrap();
let string = "Low_pq
High_pq
Low_total_acid_number
High_total_acid_number";
let substitution = "$2_$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}