import Foundation
let pattern = #"(.+\B)\s+(\1(\s+)?)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
Hey salut a tous les amis ! Hey salut a tous les amis ! #
salut a tous les amis ! Hey salut a tous les amis !
salut a tous les amis ! Hey salut a tous les amis ! #
Comment allez vous ?
Bien et toi ?
Bien et toi ? #
Comment allez vous ? #
Comment allez vous ? #
a
Salut comment vas ? Salut comment vas ? #
a
Salut ça va? salut ça va? #
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)