re = /^(?:SYSTEM )?TEMPERATURE is (.*)$/m
str = 'SYSTEM TEMPERATURE is OK
TEMPERATURE is HIGH'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end