using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<texttool.*rect=\""55\,306\,319\,23\""(?:.|\n)*?<\/texttool>)";
string input = @" text before<texttool id=""468"" rect=""55,306,319,23"">
<toolstroke />
<toolcolor />
<font style=""2"" size=""18"" />
<Text>(Be sure to state the page/problem number.)</Text>
</texttool> text after
<texttool id=""468"" rect=""5,306,319,23"">
<toolstroke />
<toolcolor />
<font style=""2"" size=""18"" />
<Text>(Be sure to state the page/problem number.)</Text>
</texttool>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}