const regex = /(<texttool.*rect=\"55\,306\,319\,23\"(?:.|\n)*?<\/texttool>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<texttool.*rect=\\"55\\,306\\,319\\,23\\"(?:.|\\n)*?<\\\/texttool>)', 'gm')
const str = ` text before<texttool id="468" rect="55,306,319,23">
<toolstroke />
<toolcolor />
<font style="2" size="18" />
<Text>(Be sure to state the page/problem number.)</Text>
</texttool> text after
<texttool id="468" rect="5,306,319,23">
<toolstroke />
<toolcolor />
<font style="2" size="18" />
<Text>(Be sure to state the page/problem number.)</Text>
</texttool>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}