# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<texttool.*rect=\"55\,306\,319\,23\"(?:.|\n)*?<\/texttool>)"
test_str = (" text before<texttool id=\"468\" rect=\"55,306,319,23\">\n"
" <toolstroke />\n"
" <toolcolor />\n"
" <font style=\"2\" size=\"18\" />\n"
" <Text>(Be sure to state the page/problem number.)</Text>\n"
" </texttool> text after\n\n"
"<texttool id=\"468\" rect=\"5,306,319,23\">\n"
" <toolstroke />\n"
" <toolcolor />\n"
" <font style=\"2\" size=\"18\" />\n"
" <Text>(Be sure to state the page/problem number.)</Text>\n"
" </texttool>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.