using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"url\([""|']*([^)\?]+\.\w{1,5})(\?[^)""']*)?[""|']*\)";
string input = @" src: url(.. / assets / fonts / INGMeWeb - Regular.eot?v=1.2);
src: url("".. / assets / fonts / INGMeWeb - Regular.eot?v=1.2"");
src: url(.. / assets / fonts / ING.MeW.eb - Regular.eot?) format('embedded-opentype'), url("") format('woff'), url(.. / assets / fonts / INGMeWeb - Regular.ttf?v=2.3.23&w=23.34) format('truetype'), url(.. / assets / fonts / INGMeWeb - Regular.svg) format('svg');
font - style: normal
}
@font - face {
font - family: INGMeBold;
src: url("".. / assets / fonts / INGMeWeb - Bold.eot"");
src: url('.. / assets / fonts / INGMeWeb - Bold.eot') format('embedded-opentype'), url(.. / assets / fonts / INGMeWeb - Bold.woff) format('woff'), url(.. / assets / fonts / INGMeWeb - Bold.ttf) format('truetype'), url(.. / assets / fonts / INGMeWeb - Bold.svg) format('svg');
font - style: normal";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}