const regex = /play\s+([^,]+?)\s*,|show\s+(.*?)\s+profile|show\s+(\d{4})\s+season\s+of\s+([^,]+?)\s*,|i(?:'m)?\s+.*?(?:\ba\b|\ban\b)\s+(\S+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('play\\s+([^,]+?)\\s*,|show\\s+(.*?)\\s+profile|show\\s+(\\d{4})\\s+season\\s+of\\s+([^,]+?)\\s*,|i(?:\'m)?\\s+.*?(?:\\ba\\b|\\ban\\b)\\s+(\\S+)', 'gmi')
const str = `play demo-song, pattern: play {song},
show hoizer profile, pattern: show {artist} profile
show 2019 season of GOT, pattern: show {year} season of {series},
PLAY demo-song, pattern: PLay {song},
SHOW hoizer some other artists profile, pattern: show {artist} profile
show 2019 SEASON OF GOT , pattern: show {year} season of {series},
i am a student I AM A programmer i'm a suergeon pattern: I'm a {profession}, `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}