re = /play\s+([^,]+?)\s*,|show\s+(.*?)\s+profile|show\s+(\d{4})\s+season\s+of\s+([^,]+?)\s*,|i(?:'m)?\s+.*?(?:\ba\b|\ban\b)\s+(\S+)/mi
str = 'play demo-song, pattern: play {song},
show hoizer profile, pattern: show {artist} profile
show 2019 season of GOT, pattern: show {year} season of {series},
PLAY demo-song, pattern: PLay {song},
SHOW hoizer some other artists profile, pattern: show {artist} profile
show 2019 SEASON OF GOT , pattern: show {year} season of {series},
i am a student I AM A programmer i\'m a suergeon pattern: I\'m a {profession}, '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end