using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(H\d+)\s+([A-Za-z\s]+)(?=\s+\d+\.\d)";
string input = @"H1765 CONTI CANBERRA 13.4 278.8 CISC TSI 28/23:00 Sa 28/13:00 28/15 00/15 1595 1700";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}