re = /(H\d+)\s+([A-Za-z\s]+)(?=\s+\d+\.\d)/
str = 'H1765 CONTI CANBERRA 13.4 278.8 CISC TSI 28/23:00 Sa 28/13:00 28/15 00/15 1595 1700'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end