using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",?[^u][^k]:\d+,\d+,\w,\w+,\w+";
string substitution = @"";
string input = @"ro:2581,1309531682152,A,Place,Page,me:2642,1310989368864,A,Place,Page,uk:2556,1309267095061,A,Place,Page,me:2642,1310989380238,D,Place,Page,me:2642,1334659643627,D,Place,Page,ro:3562,1378721526696,A,Place,Page,uk:1319,1309337246675,D,Place,Page,ro:2581,1379500694666,D,Place,Page,uk:1319,1309337246675,A,Place,Page";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}