re = /[Pp]alette[\w, ]+(?:No[ .]+|#)([A-Z0-9]+)/
str = '1. Warehouse A, (Palette #91L41)
2. Warehouse B Palette No. 214
3. Warehouse Lot Storage C (Palette No. 9)
4. Store Location D of Palette (Palette #1)
5. Store Location E of Palette, Empty, lot #45'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end