#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^:\n]+://)?([^:#/\n]*)"
Local $sString = "http://www.google.com/" & @CRLF & _
"https://www.google.com:2000/" & @CRLF & _
"http://100.1.25.3:8000/foo/bar?abc.php=xxxx+xxxx" & @CRLF & _
"www.google.com" & @CRLF & _
"10.0.2.2:5000" & @CRLF & _
"localhost/" & @CRLF & _
"localhost/foo" & @CRLF & _
"google.com" & @CRLF & _
"http://///x"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")